افزونه‌ی وردپرسی NextGen Gallery با ۸۰۰ هزار نصب، امکان آپلود فایل به صورت دسته‌ای، وارد کردن metadata و ویرایش thumbnailها را فراهم می‌کند.
اخیراً محققان امنیتی در Wordfence از وجود دو آسیب‌پذیری با شدت بالا از نوع CSRF در این افزونه خبر دادند.

برای دیدن سایز بزرگ روی عکس کلیک کنید  نام: nextgen-gallery-review.png
مشاهده: 17
حجم: 383.0 کیلو بایت

بروزرسانی این افزونه که در آن دو آسیب‌پذیری مذکور وصله شده است در تاریخ ۲۶ آذر ماه منتشر و جزییات فنی آن در تاریخ ۲۰ بهمن ماه منتشر شده است.
توصیه می‌گردد مدیران سایت‌های وردپرسی که از این افزونه استفاده می‌کنند هر چه سریع‌تر به بروزرسانی آن به نسخه ۳.۵.۰ اقدام کنند.

بهره‌برداری از این آسیب‌پذیری‌ها می‌تواند منجر به تهدیدات مختلفی مانند تصاحب سایت توسط مهاجم، redirectهای مخرب، فیشینگ و بسیاری اقدامات مخرب دیگر شود.

آسیب‌پذیری بحرانی با شناسه CVE-2020-35942 و شدت ۹.۸ از نوع CSRF در این افزونه و در تابع is_authorized_request وجود دارد که برای بهره‌برداری از آن، مهاجم باید با روش‌های مهندسی اجتماعی مدیر سایت را برای کلیک بر روی یک لینک فریب دهد.

آسیب‌پذیری مشابه دیگری با شناسه CVE-2020-35943 و شدت ۸.۸ در این افزونه و در تابع validate_ajax_request وجود دارد که برای بهره‌برداری از آن مجدداً مدیر سایت باید بر روی یک لینک کلیک کند و بدین طریق موجب ارسال درخواست آپلود یک فایل تصویری مخرب شود. این فایل تصویری که به ظاهر معتبر است می‌تواند حاوی کدهای اجرایی PHP یا وب‌شل باشد.


دوست داشتید؟ لطفا با دوستان خود به اشتراک بگذارید.

89
89 امتیاز

یک نظر

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

واکنش شما به این مطلب چیست ؟

جالب جالب
5
جالب
خنده‌دار خنده‌دار
4
خنده‌دار
انزجار انزجار
2
انزجار
عجیب عجیب
2
عجیب
ناراحت ناراحت
1
ناراحت
بد بد
6
بد
باحال باحال
6
باحال
خوب خوب
4
خوب
ترسناک ترسناک
3
ترسناک